Usage of API documented as @since 1.6+

在idea中使用lambda表达式时,收到了如下提示:

image

提示我使用的JDK版本不支持lambda表达式——虽然我已经安装配置了jdk1.8,并在pom中指定编译级别和source级别为1.8。

后来在stackoverflow找到了解决方案:

依次打开Project Settings -> Modules -> “Your Module Name” -> Sources -> Language Level,然后选择恰当的Language Level就可以了。

就这样。

##########


发表评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据